Need a new web host or having a problem with a script? Tips and advice on the best way to design, build and maintain your most valuable asset - your website!

Sub Domain Issues On XsitePro

sandyt
Posts: 2
Joined: 22 Nov 08
Trust:

Sub Domain Issues On XsitePro

I have a site, let's say website.com as the main domain in my shared hosting account with Hostgator. I recently added a subdomain, say subdomain.com and have located all folders for the sub inside website.com/public_html/subdomain.com. All seems to work and I have published subdomain.com. However I have two problems that support at XsitePro aren't able to fix (yet!) . I can't generate a google.xml map because Xsitepro won't let me change the root to subdomain.com. Google of course then creates a sitemap for website.com. Doing things manually through my Google account doesn't work either because Xsitepro won't let website.com out of the root driving seat.

Problem two seems related. When I launch subdomain.com, all looks pretty, and as intended. I land on my home page as expected. However, when I navigate away from home to another page then return home via my site link, I am taken to website.com/index.html, not subdomain.com/index.html. I can navigate back to home on subdomain by using the site map I genrate on the left panel.

Any help greatly appreciated,
Sandy
  • 0
Site Admin
mikeantiga
Posts: 793
Joined: 28 Mar 10
Trust:
Hi Sandy,

Please make sure you modify the "Publishing Details" tab of your website in XSitePro. On the Publishing Details tab, enter the corresponding information based on my example below:

Web server details:
Domain name: subdomain.yourdomain.com (your subdomain URL)
Home Directory: /

FTP server details:
FTP server: ftp.yourdomain.com
FTP directory: public_html/yoursubdirectory ( the subdirectory to which the subdomain is mapped into)

Make sure you save the settings and then republish your website once again. After republishing your website, clear your browser's cache and then reload your website. You'll notice that the links to your pages are now using the subdomain format. This should also fix the URLs on your Sitemap.
  • 0
Want lessons on Affiliate Marketing, SEO and Content Creation? Get them here for FREE:
http://www.affilorama.com/lessons
 
sandyt
Posts: 2
Joined: 22 Nov 08
Trust:
Thanks Mike,
Problem fixed. The info I had came from Mark Ling's video 3A in Afiloblueprint2. The advice there is to keep yourdomain.com as the domain name, not yoursubdomain.com. I guess we'll need to work on Aletta to fix that one!
Thanks again,
Sandy
  • 0
Site Admin
mikeantiga
Posts: 793
Joined: 28 Mar 10
Trust:
Hi Sandy, most people prefer to use the domain itself rather than a subdomain when creating a website so the option of publishing to a subdomain was not discussed on the video. But I thank you for your raising this question on this forum. This will surely help other advanced users who prefer publishing their XSitePro-based website on a subdomain.
  • 0
Want lessons on Affiliate Marketing, SEO and Content Creation? Get them here for FREE:
http://www.affilorama.com/lessons
 
Site Admin
aletta
Posts: 3719
Joined: 09 Jul 06
Trust:
I think you're the first person we've met who is using a subdomain. Since it's not what we recommended in the Blueprint, we didn't cover it in the lesson!

I did however create an extra video on using "addon domains" with XSitePro and Wordpress. The stuff in there would also apply to subdomains.
  • 0
Are your changes not showing up on your website? Try doing a hard refresh! http://www.refreshyourcache.com/en/cache/
 
paul naples
Posts: 3
Joined: 20 Sep 10
Trust:
Hi,

I'm having a similar but I think different problem I hope you guys can help.

So far I have one site built and running fine and decided to start a second one by using an add-on domain in hostgator. I've created a basic shell and uploaded it to check everything works fine. The upload was ok so I know that works properly but when I click on the page I've designated as this new site's home page I've redirected to the home page of site No.1.

If I type the URL of the new site into the address bar it takes me to the correct home page of site No.2 but if I click onto another page in that site then click on the home page again I return to the home page of site No.1

Any help is greatly appreciated. Thanks
  • 0
Site Admin
mikeantiga
Posts: 793
Joined: 28 Mar 10
Trust:
Hi Paul,

Can you please check your add domain in your Hostgator control panel and make sure it is properly mapped into a different directory? It could be possible that your 2nd domain is mapped in the same directory that was why it was redirecting to the old site.

You may also post your website URLs here (old and new) so that we can see how it is being redirected.
  • 0
Want lessons on Affiliate Marketing, SEO and Content Creation? Get them here for FREE:
http://www.affilorama.com/lessons
 

This topic was started on May 24, 2010 and has been closed due to inactivity. If you want to discuss this topic further, please create a new forum topic.