Want to work your way up in SERPs? Get and share ideas on link building, on/off page optimizing, social SEO and more.

SEO Meta not showing up in Google search

bretwefun
Posts: 24
Joined: 18 May 09
Trust:

SEO Meta not showing up in Google search

Hello All,

Recently I attempted to take what I have learned from Affilorama and use it to build a site not for Affiliate products, but for a service, and as a 'sister' site to a busniesses main site.

The sister site that I put together, http://www.atlanta-geothermal.com, does not seem to be ranking very well at all, and this is after weeks of AMA article back linking, as well as strong on page SEO.

If you do a google search for this phrase

atlanta geothermal

You will find http://www.atlanta-geothermal.com on Page 4. You will also NOT see any of the META description data in google, but if you view the page source for the index of atlanta-geothermal.com, the meta data is there.

I can not figure out why google is not reading that META information, and I am confident that whatever the reason is, that is what is causing us to rank so low.

ANYONE have any ideas on whats up? I am using the Affiloblueprint theme for that site and All In One SEO like I use for all my other sites with no issues.

Bret
  • 0
Last edited by bretwefun on 25 Jan 10 11:21 pm, edited 2 times in total.
 

faradina
Posts: 2171
Joined: 01 Jun 09
Trust:
Looking at the source of Atlanta Geothermal homepage I see this meta tag:
<meta name='robots' content='noindex,nofollow' />
That basically tells the search engines to not index your website. That would also be why none of the meta data is showing.
You can change it by going to your WP Dashboard, then to Settings > Privacy. Once there you need to select "I would like my blog to be visible to everyone, including search engines (like Google, Sphere, Technorati) and archivers" and then save the change.
I read somewhere that noindex, nofollow became the default setting for wordpress since version 2.8 so it would be good for everyone who uses wordpress to check on the privacy settings of the wordpress installation.
  • 0
bretwefun
Posts: 24
Joined: 18 May 09
Trust:
Thanks Faradin, I found the setting and made the change.

I can not believe I missed that...And what a terrible 'default' setting

Bret
  • 0
bretwefun
Posts: 24
Joined: 18 May 09
Trust:
I wanted to come back to this.

This weekend I did notice the nofollow code but was digging through the header code and the All In One pack trying to get rid of it.

Making the change to this setting definitely removed the nofollow meta code.

As well I did a test install of Wordpress 2.9.1, by default the setting went to "I would like my blog to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers"

Anyways, thanks for the heads up on the easy fix.

B
  • 0

This topic was started on Jan 04, 2010 and has been closed due to inactivity. If you want to discuss this topic further, please create a new forum topic.