Struggling with Adwords or Yahoo Advertising? Find and discuss ways to improve your CPC, ROI or conversion rate. Get advice and share ideas on ad copy.

Using noindex on PPC Page to Prevent Duplicate Content

PremiumMember
julia82
Posts: 13
Joined: 21 Nov 08
Trust:

Using noindex on PPC Page to Prevent Duplicate Content

Hi,

Let say I want to run PPC.

I am using a landing page that have exactly the same content as one of the pages in my side.

So, in order to avoid duplicate content penalty, I will add in the following code in my landing page.

<meta name="robots" content="noindex,nofollow" />

Is doing that good enough? Or do I need to do more than that?

And also, can you help me check if the code above is correct?
  • 1
johncrosbie
Posts: 13
Joined: 29 Apr 09
Trust:
Julia,

Those meta tags work well on a regular site (i.e., not WordPress).

And if you're on WordPress, install the Robots Meta plugin, then click the noindex, nofollow radio button on your PPC page (and index, follow on your SEO pages).

All the best.

John
  • 1
PremiumMember
perswealth
Posts: 38
Joined: 24 Jun 09
Trust:
Hello John,

this is actually great advice, as i was going to use a landing page with content that was on ANOTHER part of my website. I think this should be mentioned in the course, as i'm sure many others would've been penalized for this.

John, my question is, after installing this plugin, then make my landing page, how do i go to this radio button?
  • 1
jasondodd
Posts: 874
Joined: 08 Feb 09
Trust:
After installing a plugin you need to make sure its activated and then these meta options should appear when you edit or add a page in WordPress.
  • 1
Limited time special - Try Affilorama Premium for just $1 for 7 days: http://www.affilorama.com/premium
 
PremiumMember
perswealth
Posts: 38
Joined: 24 Jun 09
Trust:
I see. Thanks Jason
  • 1
jjperkins
Posts: 201
Joined: 29 Apr 09
Trust:
Has anybody had success with the Robots Meta plug in?
We've installed it, activated it but the radio button won't stick on no follow, no index.

I think it must be something in settings we need to chamge?
Groping around blindly here, would really appreciate a hint :-)

J & J
  • 1

 

This topic was started on Jun 24, 2009 and has been closed due to inactivity. If you want to discuss this topic further, please create a new forum topic.