Need a new web host or having a problem with a script? Tips and advice on the best way to design, build and maintain your most valuable asset - your website!

New Permalink Structure Not Working?

packardsking
Posts: 25
Joined: 08 Dec 13
Trust:

New Permalink Structure Not Working?

I am trying to customize the my WP permalink. Earlier I had set the permalink to be
example.com/postname . my site was working fine.
however, now I'm trying to update it to example.com/category/postname . The url structure is getting updated fine. But the pages are showing 404error. Can tanyone tell me what might be the issue?
  • 0
Top Webhosting services and All about hosting
http://www.topwebhostings.info/
 
Site Admin
cecille.l
Posts: 6963
Joined: 25 Feb 11
Trust:
I suggest you check the new URL structure in Settings > Permalink. Make sure that it looks like this : /%category%/%postname%/

If there is an error in the structure, then the links will not be updated accordingly so the pages will not be accessible.

If the issue persists, please let us know. If possible, please post a screenshot so we could look into the issue further.

Hope that helps. Have a good day!
  • 0
Cecille


Step by step guide to "Penguin-proofed" sites : www.affilorama.com/affiloblueprint


Add us on Google Plus: http://www.affilorama.com/googleplus
 
packardsking
Posts: 25
Joined: 08 Dec 13
Trust:
Yes, I'm using exactly the same format...
The permalink structure gets updated and looks fine. But when I access the page it gives error.

I included the screenshots below. However, now im switching it back to just '%postname%/', so that visitors don see error on my site. But I really want to include category as well in the permalink.. pls help.

https://www.mangalorevisit.in:2083/cpse ... =&basedir=

https://www.mangalorevisit.in:2083/cpse ... =&basedir=

https://www.mangalorevisit.in:2083/cpse ... =&basedir=
  • 0
Top Webhosting services and All about hosting
http://www.topwebhostings.info/
 
cliftoraf
Posts: 12
Joined: 20 Oct 14
Trust:
did you upload the .htaccess file to your blogs' root directory?
  • 0
packardsking
Posts: 25
Joined: 08 Dec 13
Trust:
cliftoraf wrote:did you upload the .htaccess file to your blogs' root directory?

Yes ofcourse.. Thanks for ur reply. Issue is no fixed. Yeyy!!
  • 0
Top Webhosting services and All about hosting
http://www.topwebhostings.info/
 
packardsking
Posts: 25
Joined: 08 Dec 13
Trust:
I fixed the issue somehow. I thot I will share the fix with all of u, so that you can refer it in case u too face similar issue. If anyone has alternative fixes, please suggest.
http://www.topwebhostings.info/news-blo ... -permalink
  • 0
Top Webhosting services and All about hosting
http://www.topwebhostings.info/
 
dmitriygloria
Posts: 9
Joined: 20 Oct 14
Trust:
Please check your mod_rewrite is enabled on your server? Please check your .htaccess you can use to test it:

Options +FollowSymLinks
RewriteEngine on
RewriteRule ^home/$ /index.php [L]

With this, if home/ goes to index.php, it's working. If not, contact your provider to see if they allow it/can turn it on, etc.
  • 0

This topic was started on Nov 26, 2014 and has been closed due to inactivity. If you want to discuss this topic further, please create a new forum topic.