Home » Affilorama forum » Website Building » Having a ton of problems with XsitePro Website
Need a new web host or having a problem with a script? Tips and advice on the best way to design, build and maintain your most valuable asset - your website!

Having a ton of problems with XsitePro Website

marymeagan
Posts: 338
Joined: 29 Nov 09
Trust:

Having a ton of problems with XsitePro Website

I know this is supposed to be an easy tool to use but I got snagged on something which all started when I chose Namecheap as my domain and host instead of HostGator.

Apparently there are different settings in XSP for the 2 different hosts and I followed the tutorials Mark and Aletta who taught me the HostGator way and have been having a lot of trouble ever since (wish I'd chosen Hostgator now)

I find it very difficult to explain some of these problems here because I can understand my thinking of what I am trying to say but even Mark was a bit unsure of what I was asking in one post and I thought it was very clear

I'm going to be in the beginning of week 4 for some time until I get these problems sorted out (so I'll ask again)

#1- when I go to page layout it displays my web site but has the (example text in the main panel instead of my web page) and I can't change it, when Aletta pressed page layout her web page appeared.

#2- In page layout I used the same pixel dimensions as Aletta but my web site is much smaller (but then I'm working with the example page still on my site which might the problem)

#3- I received 7 more articles and added them to my site including the affiliate hoplinks and when I clicked through to the buyer's page with my link then to the Clickbank purchase page, my username is not beside Affiliate =, My first 3 articles are alright but my last 7 are not. (is this a publish problem maybe ?)

#4 - In XsitePro again, I followed Aletta to click on" Other" then to "file name settings" and Aletta set hers to PHP from HTML and I did the same, but now I can't preview my web site, I went back to "file name settings" and changed it back to HTML and now I can preview my web site, But not sure if this is right or wrong to do.

I don't want to continue building my web site until I find out what's causing these problems which I feel will only get bigger if I continue, It might have been something small but I believe I copied Aletta properly right to the end of week 3 and the problems started the first lesson of week 4

I am currently waiting for access to the XSP forum to ask these questions there, plus their FAQs does not list any of my problems

Sorry to be a pain but I hope my questions are understandale

Larry
  • 1
Last edited by michellerana on 17 Jan 10 2:27 am, edited 1 time in total.
Reason: improve title
 

Larry Bauge
 
nakibk
Posts: 34
Joined: 29 Apr 09
Trust:
Hey Larry,

#4 happened to me too, so that's the only one I can help you with. Basically, when you changed files to PHP you can't preview it on your local computer because PHP needs a server to run on (provided by hosting services). So just leave it at HTML untill you manage to publish the site online. Then you can change it to PHP.

Let me know if any part of that wasn't clear enough. Hope you get help sorting out the other ones :)
  • 1
Moderator
wollowra
Posts: 1292
Joined: 14 Mar 08
Trust:
Hi Larry,

1. You need to go into web pages, click on the web page you have created
for Example: mypage1 and then click on DESIGN.
Then you put your content in.

2. You may need to adjust your footer, header and left and right sidebar widths. Also set your content panel width.

3. Not sure, just check that ALL your links are properly addressed.

4. Answered by Nak

Hope that helps.

Regards
Troy
  • 1
Enjoy the little things, for one day you may look back and realize
they were the big things.

-- Robert Brault
 
marymeagan
Posts: 338
Joined: 29 Nov 09
Trust:
Hi Wollowra


I did as you said and clicked on web pages which showed on the left all 10 of my pages, I then clicked on the first page which appeared, the only problem here is that I am already in design because the Web Pages and Design boxes are joined.

Plus all my articles content has been installed in the "Web Pages + Design" page of XSP

What I'm trying to say is when I click on Page Layout, Why doesn't my web site appear with the content of my article in the main panel.

What does appear is my web site with (Here's an example of what a typical page will look like), this is the XSP example site that we delete to add our article content to in web pages + design, and how do I get rid of it and display my web page instead

But in Page Layout when I click on one of my pages I get this pop up saying "This is a preview of your page layout, The navigation on this page has been disabled" (how do I get out of the preview mode)

So I've run out of options of how to get my web site into Page Layout with my page displayed in the main panel instead of the XSP sample page (it might be I don't know how to exit Preview, I did click on Preview at the bottom left corner about 4 days ago and now I can't get out of it)

I'm sorry for being long winded but I hope I am understood as it's difficult to relate problems to seasoned marketers hoping they understand my problem with my explanation LOL.

Larry

Larry
  • 1
Larry Bauge
 
Moderator
wollowra
Posts: 1292
Joined: 14 Mar 08
Trust:
Hi Larry,
Have you gone into WEB PAGES and then PAGE SETTINGS and put a tick in the spot where it say's
"Make this my home page" ( Only tick this for your main home page )
and "Show on left navigation menu"
and "Publish this web page" ?

Also, it may be that you have .php as the default type instead of .html
You have 3 options here...

1. What you can do is build and preview your site in .html and once you are happy with it, you can change it back to .php.

or
2. When using the .php extension in XSitePro, you can't preview pages with that extension within XSitePro.

However, any html code in your php pages can be viewed on your PC.
Go To PUBLISH and Publish locally, and publish your site into a desktop folder on your PC.
Then right click on any file, and 'Open With' your browser.

Any php code in your page will not be viewable, since that can only be done on your server, and the raw code will show up as such, but all html code will display as normal and you should see your site.

or
3. I also think you can have your PC preview .php files. but you will need to set your pc up to do this and you will need to install some software for your PC to act as a web server for php files...this is the more difficult option.

Personally, I think option 1 would be best for you.

Regards
Troy
  • 1
Enjoy the little things, for one day you may look back and realize
they were the big things.

-- Robert Brault
 
marymeagan
Posts: 338
Joined: 29 Nov 09
Trust:
Hi Troy

That is a lot of useful info, thank you very much,

Larry
  • 1
Larry Bauge
 
marymeagan
Posts: 338
Joined: 29 Nov 09
Trust:
Hi Troy

Just one more question.

When I was in the final lesson of week 3 (how to upload your web site with XsitePro) the file web site setting is changed to PHP) but Aletta is with HostGator and I'm using Namecheap.

A little further on in publishing, Aletta said, I think it was" Public....Html" and to delete this, I tried following her lead but could not find this file or better yet it was not there and didn't understand what this meant so I left it assuming that Namecheap is different in this reguard from HostGator

So I'm just wondering, am I going to have future problems if I continue building my web site trying to follow the lessons knowing that Aletta will make other adjustments that might not be required on my web site and how would I know ?

Larry
  • 1
Larry Bauge
 
Moderator
wollowra
Posts: 1292
Joined: 14 Mar 08
Trust:
Hi Larry,
Actually, I don't get the default.html when I build my sites with xsitepro. So I do not have to delete it.
If you can not see it there, do not worry about it.
Aletta was only showing you what to do if this does happen and your website does not publish.
I am sure if Aletta sees this she can confirm it, otherwise it is fine.

Regards
Troy
  • 1
Enjoy the little things, for one day you may look back and realize
they were the big things.

-- Robert Brault
 
Site Admin
aletta
Posts: 2177
Joined: 09 Jul 06
Trust:
Goodness, Larry.

I kind of want to just fly you over here and sit you down in front of a computer and see what on EARTH you're doing! ;)

But in Page Layout when I click on one of my pages I get this pop up saying "This is a preview of your page layout, The navigation on this page has been disabled" (how do I get out of the preview mode)


Yes. You can't see the actual content of your site when you're designing the GENERAL LAYOUT of your site. This is different from designing the layout of an INDIVIDUAL PAGE in your site.

Use this panel for setting the width etc of things, if you've managed to get that working yet. You cannot use the navigation in this "example layout" to navigate around your page. It won't work. It's only for designing the general layout of your page.

When you want to edit the actual pages of your site, you need to click on WEB PAGES up the top.

The reason you're still seeing the "this is what your typical page will look like" text is because you haven't deleted the default "page 1" that your site came with. If you look at the content of this page, you'll see that it says "this is what a default page will look like".

If you go into WEB PAGES > DESIGN and click on that page, and delete all the text from that page, and replace that text with "I like pies", and then go back to PAGE LAYOUT you will see the general layout with "I like pies" on it.

If you want a real page to appear in this "page layout" tab, you need to create a "real" page, and then set it as your homepage.

Do this by going into the WEB PAGES tab, choosing the page you want to be your homepage, make sure you're on the PAGE SETTINGS tab inside the WEB PAGES tab, and then check that "make this my home page" box down the right hand side.

Does that sort that one out?

With regards to the "public html" thing.... as I said, if you publish your site and you can see it on your website just fine, no problems with that.

Where I think you might have problems is in figuring out what to enter into the publishing settings in XSitePro. It's a little different for every hosting company, and since we don't have a namecheap hosting account I can't test it for you.

You could try contacting namecheap and seeing what they say.

And if you really, really can't figure it out... you can PM me your namecheap hosting account details and I can try uploading a test site and find out what those settings are.

Once you get beyond that, there probably won't be any further difficulties. Until you decide you want to build another affiliate site, and you need to add another domain to your hosting .... but I'm guessing that won't be for a while ;)
  • 1
Are your changes not showing up on your website? Try doing a hard refresh! http://wiki.scratch.mit.edu/wiki/Hard_Refresh
 
Moderator
wollowra
Posts: 1292
Joined: 14 Mar 08
Trust:
Thanks for jumping in Aletta.
lol, I know what you mean by wanting to jump in front of their computer..lol
You think to yourself, It's gotta be something small... if I could just get my hands on their mouse..lol

Troy
  • 1
Enjoy the little things, for one day you may look back and realize
they were the big things.

-- Robert Brault
 
Site Admin
aletta
Posts: 2177
Joined: 09 Jul 06
Trust:
You know.... I think there might be technology for doing this.
Hmmmm.

(There's also this thing called the Internet... I hear it's really taking off... )
  • 1
Are your changes not showing up on your website? Try doing a hard refresh! http://wiki.scratch.mit.edu/wiki/Hard_Refresh
 
Moderator
wollowra
Posts: 1292
Joined: 14 Mar 08
Trust:
Yes, I have tried crossloop.com and that did not work too well for me.
I could use remote desktop, have not tried that yet.
Regards
Troy
  • 1
Enjoy the little things, for one day you may look back and realize
they were the big things.

-- Robert Brault
 
clarafaie
Posts: 37
Joined: 17 Aug 09
Trust:
Hi Troy,

Teamviewer works very well for me. Try it sometime.
  • 1
http://clarafaie.net
Full-featured Business web hosting, with Unlimited Data Space, Unlimited Monthly Traffic, 500 E-mail Accounts, and 20 MySQL DBs for each of up to 5 domains for only US$90 a year. Also available: Starter, Corporate, and Enterprise plans
We also setup and/or migrate your WordPress sites to our servers for you. Email wpsolutions@clarafaie.net for more information.
 
Moderator
wollowra
Posts: 1292
Joined: 14 Mar 08
Trust:
ok, thanks for the info.
Regards
Troy
  • 1
Enjoy the little things, for one day you may look back and realize
they were the big things.

-- Robert Brault
 
ablewebs
Posts: 9
Joined: 04 Jul 10
Trust:
Wow, I hate to see all these issues with getting XSitePro up and running! I'm an XSitePro guru and very accessible. You can email me or call me directly and I'll help you! If it's a quick answer, I don't charge you anything at all. If we get into a long training/consulting situation, yes, there would be a charge, but it saves you from wasting a lot of time, pulling out your hair and melting down.

Regards,
Andrea
  • 1
Andrea Wilson
XSitePro Designs
http://www.XSiteProDesigns.com
 
PremiumMember
robynm
Posts: 62
Joined: 23 Apr 09
Trust:
Ever since I have upgraded xsitepro in Jan. I have had problems
Has anyone else experienced any problems from the upgraded version?
  • 1
ablewebs
Posts: 9
Joined: 04 Jul 10
Trust:
Hi, Robyn,

Can you give me the specific issues you're having and I'll test them out for you. Have you reported your issues to Intellimon's customer support? If so, what did they say? If not, I would encourage you to do so. Also, have you checked for the issues you're having on the XSitePro forum?
  • 1
Andrea Wilson
XSitePro Designs
http://www.XSiteProDesigns.com
 
PremiumMember
robynm
Posts: 62
Joined: 23 Apr 09
Trust:
Hi Andrea,
my text links don't work once published, but the image ones do.
also the source looks real crazy.

I have contacted support, and waiting on an answer, I tried nutting it out myself and looked through the xsitepro forum and the Affilorama forum.

If they cannot help, I'll return here thanks for asking
  • 1
Site Admin
mikeantiga
Posts: 740
Joined: 28 Mar 10
Trust:
Hi Robynm,

You may also send us an email with the specific web page where the error/issue exists so that we can help you diagnose the cause of the issue.
  • 1
Want lessons on Affiliate Marketing, SEO and Content Creation? Get them here for FREE:
http://www.affilorama.com/lessons
 
ablewebs
Posts: 9
Joined: 04 Jul 10
Trust:
Hi, Robyn,

Thank you for the PM. I had a look at your Source Code and I can see that you pasted in your text from MS Word. That's where all the crazy code is coming from. I recommend never copying from MS Word, but, instead, typing directly into XSitePro's Design view. If you have to copy from MS Word, paste the text into a text editor like NotePad or Word Pad first. That will strip out the messy formatting code. Note: The "Paste from Word" option in XSitePro doesn't clean up all the issues with pasting from MS Word, unfortunately.

I have seen the issue with the text links before, but I'll have to do some research for you as I don't remember the solution. Meanwhile can you let me know what version of XSP you are on. Please go to the toolbar and click on Help > About XSitePro and send me the long string of numbers at the very bottom of the pop-up.

I will be away from my desk for a few hours today, but I will try to research this issue for you as soon as I get home.
  • 1
Andrea Wilson
XSitePro Designs
http://www.XSiteProDesigns.com
 
ablewebs
Posts: 9
Joined: 04 Jul 10
Trust:
Hi, Robyn,

Can you please try adding the text link on a clean/empty page with no text pasted in from MS Word. I tried to find the answer on the XSP forum, but I can't seem to locate it it. I know it's there somewhere, but my keyword searches aren't bringing it up. So we need to try the obvious: make sure you're not on a release with known issues, eliminate the MS Word formatting. If a clean page doesn't resolve the issue, please send me your version number. Also, let me know if you hear back from XSP Support.
  • 1
Andrea Wilson
XSitePro Designs
http://www.XSiteProDesigns.com
 
PremiumMember
robynm
Posts: 62
Joined: 23 Apr 09
Trust:
Hi Andrea
I have received a reply for support as follows

There are two possibilities here.
Either there was a data glitch in the website, or there was a formatting error on the web page.

If this is a glitch in this website.
Please export the website to an XSE file and then re-import it.
The import function will read the XSE file and fix any known errors. :)

If this is an error in the formatting, then the easiest option is to re-insert the links.
The editor in XSitePro is self correcting, so it should fix most errors automatically.

However Andrea I may try your idea first by placing text from wordpad. then try the first suggestion that support gave.
I'll let you know how I go.
I had xstiepro 2 and upgraded to xsitepro2.5.
I'll let you know how I go and thanks for the support!!

Thanks Mike, I'll email you the page :)
  • 1
ablewebs
Posts: 9
Joined: 04 Jul 10
Trust:
Hi, Robyn,

Yes, they are saying the same thing as I did when they say there may be a "formatting error" on the Web page, so a clean page should resolve that!
  • 1
Andrea Wilson
XSitePro Designs
http://www.XSiteProDesigns.com
 
PremiumMember
robynm
Posts: 62
Joined: 23 Apr 09
Trust:
Hi Andrea
I am VERY pleased to say that I followed your advice and I have now published those two pages.
I made new pages, but it was copying my article from wordpad not MS Word that did the trick. I must remember not to use MS word again.

The source looks normal and the links worked straight away.

I am soooo very grateful, I will send "xsitepro help" an email and inform them that the issue is solved.

Thankyou, Thankyou. invoice me if you want.......I am so relieved :)
  • 1
ablewebs
Posts: 9
Joined: 04 Jul 10
Trust:
Hi, Robyn,

I am so happy that's all it was! No charge! Glad to be of service. :)
  • 1
Andrea Wilson
XSitePro Designs
http://www.XSiteProDesigns.com
 
ttramblie
Posts: 4
Joined: 21 Jun 10
Trust:
Hello,

I'm having some problems with my links in xsitepro! When I add a link to a page it will work but then when I add the same link or another link on a different spot on the page it usually cancels out the original link! The other thing that happens is sometimes it will work and then when I publish my site, the links are gone so nobody can click on my promoted products! Very frustrating!!

Can anyone help me with this???

Thanks!

Tanner Tramblie
  • 1
ablewebs
Posts: 9
Joined: 04 Jul 10
Trust:
Hi, Tanner,

I have seen your problem before. I can't remember the solution, but I don't think it's an issue with the latest version. What version of XSitePro are you on? Have you updated to the latest release? v2.504?

If updating doesn't resolve your issue, please let me know and I'll look into it further!
  • 1
Andrea Wilson
XSitePro Designs
http://www.XSiteProDesigns.com
 
PremiumMember
elogic0007
Posts: 78
Joined: 24 Jun 09
Trust:
Hi everyone,
I updated my xsitepro software two weeks ago and ever since then i cannot view my articles in design view, has anyone seen this problem before?

thanks
  • 1
Moderator
wollowra
Posts: 1292
Joined: 14 Mar 08
Trust:
I have not come across this problem.
If no one here can help you maybe you can ask on the xsitepro forum.
http://www.xsitepro.com/messageboard/

Regards
Troy
  • 1
Enjoy the little things, for one day you may look back and realize
they were the big things.

-- Robert Brault
 
curtismrasmussen
Posts: 2
Joined: 21 Oct 11
Trust:
xSitePro user. I tried another template (5 or so) just to see what they would do to my website and although I didn't save the website with any of the changes the experiment has left a permanent set of vertical grey stripes on every page. I've been through every bit of source code and I cannot identify why they are there.

I even went back and restored an earlier version of my website and the stupid lines still persist!!!

HELP!
  • 1
Curtis
 
Moderator
wollowra
Posts: 1292
Joined: 14 Mar 08
Trust:
Hi Curtis,
All I can think of is that your panel widths are messed up.
Check or play around with your header panel and content area etc or side panels.
You can also check out the xsitepro forums as I pointed out above.
A picture of the problem would explain it better...
Hope you get it sorted.
Regards
Troy
  • 1
Enjoy the little things, for one day you may look back and realize
they were the big things.

-- Robert Brault
 
etfimt
Posts: 145
Joined: 31 Mar 12
Trust:
Hi guys i am new to xsitepro2.5 and i am completely lost how to add right ( extra ) panel to the page .
Templates included in program are just one panel sided is either left or just few of the templates with the right.
How to do it so you have 2 panels one on the left and one on the right .
Since i would like to have menu on the left , i would like to have some product i want to promote with the news letter on the right plus some adsence.
And of course in the middle some content with out page being squeezed .
I am going thru all of this lessons and didn't found yet how to add second side panel to the page .
I don't want to use serif software because i will get no access to some futures like clickbank , but i think xsitepro is not that easy to build up on the page how is advertized .
i added some pictures to the gallery and now i have problem to remove them because there is no delete function in the gallery .
And how do you resize the page , this should be easy to do function , if it wouldn't be for the header i would have no idea how wide my pages are .Sorry to complain but maybe finally someone will help me out with adding second panel with out header to being scramble up .
Thanks Eva
  • 1
Site Admin
cecille.l
Posts: 5760
Joined: 25 Feb 11
Trust:
Hi Eva,

I am not well-versed in using XSite Pro so I have put this question to a member of our technical staff and let you know as soon as I have feedback.

You might also want to check the support forums for XSite Pro for assistance.

I appreciate your patience. Have a good day!
  • 0
Cecille


Step by step guide to "Penguin-proofed" sites : www.affilorama.com/affiloblueprint


Add us on Google Plus: http://www.affilorama.com/googleplus
 
etfimt
Posts: 145
Joined: 31 Mar 12
Trust:
HI Cecille actually i already learned how to do a lot of with xsitepro i started from building from the scratch and this helped to learn where and how to do it .
I am still watching video tutorials if i have some problems i wish xsitepr2.5 would have little more functions with graphics like moving stuff around mowing text around just with the mouse arrow or add shadows to text or pictures .
But overall i like it i think one more month and all should be clear , thanks Eva
  • 0